What browser do I need to work with my shop control panel?

 

The current supported browsers for the Powa Control Panel are as follows:

  • Windows
    • Internet Explorer 8 or higher
    • Mozilla Firefox 
    • Chrome 
  • Mac
    • Safari 5 or higher
    • Mozilla Firefox

 

Have more questions? Submit a request

0 Comments

Article is closed for comments.